Page 1 of 1

Muxing fails when transcoding large files using SVE

Posted: Tue Jan 10, 2017 3:07 am
by nickc
Muxing fails (code 15) when transcoding large h.264 files (11GB-16GB) to H.265 using SVE. The actual encoding process completes successfully but muxing always fails and the transcoded file is not generated. Looking at the log, I think SVE generates too many segments to CONCAT together, I think the CONCAT string is too long.

As a test I tried switching from MP4Box to ffmpeg but this also failed at muxing.

I then tried transcoding only the first 5 minutes of an hour long h.264 11GB file and the process including muxing completed successfully. I then turned off SVE and transcoded the entire file successfully including muxing.

Muxing these files without SVE takes around 40% longer (i.e. 60 minutes longer) on an 8 core Intel 5960X processor using X265. Clearly SVE is a significant feature and one of the main reasons I purchased the software, so I hope this can be fixed for the next release.

As a suggestion, would it not be possible for SVE to simply split the file based on the number of concurrent segments specified rather than into hundreds or thousands of segments? Or Mux completed segments together during the transcoding phase?