MC-0.8.63: cannot run source filter Mencoder with multithread

Bug report and feature request
Post Reply
kawamoto76
Advanced
Advanced
Posts: 476
Joined: Sun Dec 14, 2008 4:52 pm
Location: JAPAN

MC-0.8.63: cannot run source filter Mencoder with multithread

Post by kawamoto76 » Fri Jan 15, 2021 6:46 pm

Last year, I posted into "General Discussions" the same problem as to MC-0.8.61.
And it has not been improved yet even as to MC-0.8.63.

When Mencoder is used as source filter, conversion speed is too slow than that when ffpmeg used.
In my typically case, ffmpeg gives 4.0x, Mencoder gives 1.6x. Mencoder gives much slower speed !
I use 16core-32thread dual-Xeon system.
Viewing the performance with Windows TaskManager, there is 32 logical CPUs.
CPUs' performance is observed during conversions, usage results are as follows.
(1)When Mencoder is used as source
only 1 CPU is about 90%, 16 CPU are about 20-30%(average), rest 15 CPU are few percents.
(2)When ffmpeg is used as source
all 32 CPU are 80-90%.

I suppose, in Mediacoder, x264 encoder will receive input through the pipe from source filter such as Mencoder or ffmpeg.
When Mencoder is used for source filter, only one processor seems to be used for input source filtering as TaskManeger shows.
It is obvious, x264 uses multi-thread. Also ffmpeg uses multi-thread.
On the other hand, Mencoder may use only 1 CPU. Mencoder's process acts as a bottle-neck, totally processing speed is suppressed.

Mencoder itself can utilize multithread operation.
However, It is not true when used in MC-0.8.63 as source decoder.
There, Mencoder runs with single thread only.

Parameter settings are below,
Tasking: all cores(32CPU in my system)
Input source: 3,2-pulldowned mpeg2-aac TS file(1920x1080,29.97i, 17Mbps)
Target output: H.264/AC3 m2ts file, 23.976fps, progressive, 4000kbpsAVR, audio-448kbps
video source decoder: Mencoder or ffmpeg
video output format: H.264
video encoder: x.264
video out Rate mode : AVR
audio source decoder: Auto(Default)
audio output format: AC-3
audio encoder: Auto(ffmpeg)
output container: M2TS
Picture Effect from: Source_Filters
IVTC mode select: File -> Settings -> Video_filters -> Inverse_Telecine_Filter -> pullup(or primitive)
Akira Kawamoto

Post Reply