Search found 39 matches

by velis
Sun Jan 10, 2010 10:47 am
Forum: Generic Discussions
Topic: VC1 + AC3 problems
Replies: 0
Views: 2397

VC1 + AC3 problems

I'm just remuxing my blu-rays. That is, taking base movie stream, extract the VC1 and AC3 streams and mux them together into MKV. I have two problems with this: 1. If AC3 stream is AC3 HD, Haali won't even detect it as audio. ??? I don't modify it in any way, so what gives? 2. If I mux a normal AC3 ...
by velis
Sun May 03, 2009 6:45 am
Forum: Generic Discussions
Topic: [Tip] Using YADIF mode 1 deinterlacer
Replies: 0
Views: 3838

[Tip] Using YADIF mode 1 deinterlacer

Me being such a n00b I spent quite a while discovering how to encode progressive video from interlaced source. I wanted to use mode 1 for Yadif filter since this filter yields the best result for me. Mode 1 in addition "doubles" the frame rate which I wanted to have since this is in my opinion the o...
by velis
Sun May 03, 2009 6:30 am
Forum: Generic Discussions
Topic: [Tip] Not all audio streams convert to AAC
Replies: 0
Views: 1925

[Tip] Not all audio streams convert to AAC

Just spent a day figuring out what the problem was. I had some .AVIs with MONO 11024 Hz PCM audio. The encoder would simply stop somewhere during 2nd pass and there was no parameter that would help resolve the issue. MediaCoder reported "The decoding thread seems to be blocked...". In the end I manu...
by velis
Wed Apr 29, 2009 9:57 pm
Forum: Generic Discussions
Topic: HTPC to play H264 with hardware acceleration
Replies: 2
Views: 5101

Re: HTPC to play H264 with hardware acceleration

I've researched problem further and this is what I found: mplayer (and most MCE front-ends) has VDPAU support, but only for newer nvidia graphics cards. 6600GT is left out, unfortunately. I was testing this in Ubuntu 8.1 and 9.04 and sure enough no player was able to keep up with 1080p. I have compi...
by velis
Wed Apr 29, 2009 9:06 pm
Forum: Generic Discussions
Topic: [solved]How to make x264 display PSNR and SSIM calculation
Replies: 1
Views: 3112

Re: How to make x264 display PSNR and SSIM calculation results

Finally figured it out.

One just needs to add ssim:psnr to x264 advanced/extra options.
Thanks for all the help :)
by velis
Tue Apr 21, 2009 9:06 am
Forum: Generic Discussions
Topic: "No file is outputed" when trying to make .mkv from Blu-ray
Replies: 4
Views: 11735

Re: "No file is outputed" when trying to make .mkv from Blu-ray

I believe your problem is the same as mine . It seems nobody else encodes with MEncoder to files > 1GB or it's just you and me that can't figure out how to make MEncoder work. If you adjust the settings so that temp files will not be erased, you'll see that the intermediate AVI is playable only by M...
by velis
Tue Apr 21, 2009 5:45 am
Forum: Generic Discussions
Topic: What's with the deinterlacer?
Replies: 0
Views: 2223

What's with the deinterlacer?

x264 reporting error while transcoding (still finishing ok though). It says frame count is larger at 2nd pass than at 1st pass (probably by one frame) Source is MPEG-PES, interlaced from my video camera. Used just about all filters available in the Picture / effects (Full range levels, deblocking, d...
by velis
Tue Apr 21, 2009 5:39 am
Forum: Generic Discussions
Topic: [solved]How to make x264 display PSNR and SSIM calculation
Replies: 1
Views: 3112

[solved]How to make x264 display PSNR and SSIM calculation

It has the --no-psnr and --no-ssim switches, but MC doesn't use them.
However in the [info] section at the end of encoding, all statistics are displayed but these two.

So, how do I make MC tell x264 to display the calculations for these two?
by velis
Tue Apr 21, 2009 5:33 am
Forum: Development
Topic: Build 4380 mencoder bug?
Replies: 1
Views: 4516

Re: Build 4380 mencoder bug?

I have confirmed that the MEncoder bundled with 4380 is still the faulty 4.2.4 version. By "faulty" I mean, it produces unreadable files over 1GB of size. Or at least I can't make it work right... It's funny how it reports build number 29170 while the version I found to be working fine (4.2.5 report...
by velis
Sun Apr 19, 2009 8:02 pm
Forum: Development
Topic: Build 4380 mencoder bug?
Replies: 1
Views: 4516

Build 4380 mencoder bug?

I switched to build 4380 a few days ago. x264 really is A LOT faster. However, I again have problems with files longer than 1GB, only this time the problems are different than before . The intermediate AVI (from mencoder) is just over 1GB (1092655 KB to be exact). It plays only in mencoder, VLC and ...