Audio Video Sync Issues

This area is for more experienced users, discussing about more complicated issues.

Moderator: HuggiL

Larva
Beginner
Beginner
Posts: 1
Joined: Fri Jan 18, 2008 2:36 pm

Audio Video Sync Issues

Postby Larva » Fri Jan 18, 2008 2:44 pm

I'm trying to convert a VOB (MPEG-2) to an H.264 codec in a mp4 container. However, I'm getting audio video sync issues in the converted file that doesn't exist in the original.

I'm using the following settings for audio:
Nero Encoder, LC-AAC, 128kbps

I'm using the following settings for video:
H.264, MP4, 768kbps

I'm using the following settings for picture:
320x240, Crop To Fit, 29.970 fps

Does anyone have any suggestions on what I can do to try and correct the problem? Do I need to provide more info? Is there a some place I could go for a tutorial on my specific encoding needs?

I'm sorry if this post isn't up to par, but I'm new to this whole video conversion process and MediaCoder.

Thanks in advance for your help.
mixer
Expert
Expert
Posts: 3004
Joined: Tue Jul 11, 2006 4:20 pm
Location: Portland, Oregon USA

Postby mixer » Fri Jan 18, 2008 3:06 pm

Probably not a "Basic Discussion" question so I'm moving to "General".

This also has been discussed several times in the forums, you might want to use the "Search" box and look for a/v sync....etc.

Also, the sync issue is ongoing and is being worked on. Which version do you have of MediaCoder and have you tried the more "Stable" version v.3905?

You also might want to try this as an experiment:
Setup everything as you would normally
Then click on the "Video" tab
Next, deselect/uncheck the "Auto Select" box to the right of "Backend"
Then, using the drop down arrow, choose "FFMPEG" instead of MENCODER"

You can also mess around with the audio delay

Not sure if this will work, you'll have to experiment.

Remember to "Revert" all your settings if you want to get back to the original settings.
Shlappy
Amateur
Amateur
Posts: 35
Joined: Tue Sep 11, 2007 12:06 pm
Location: Gods left handprint : Michigan USA

Postby Shlappy » Thu Jan 24, 2008 10:07 pm

zimon
Beginner
Beginner
Posts: 7
Joined: Fri Feb 22, 2008 2:40 am

use -vf harddup with mencoder

Postby zimon » Tue Feb 26, 2008 12:37 am

With mencoder one should use
-vf harddup
when encoding and later muxing with a different program. (Google with "harddup" to read longer explanation.)

MediaCoder could automatically add that "-vf harddup" to the mencoder command string as it is often needed.

Also they recommend to try "-mc 0 -noskip" in the mencoder.

I had similar issue when using x264 backend. I don't know if there is a similar flag to be set for the x264 program, but at least MediaCoder is not supporting setting up custom flags like with mencoder it is.

Will try now to use ffmpeg then to encode this video:
(MPEG2).mpg -> (H.264 + VORBIS).mp4

And I am using dev. version 4060 currently. It has totally broken preset/loading+saving currently as I have reported in BUGs section.

Return to “Advanced Discussions”

Who is online

Users browsing this forum: No registered users and 1 guest