cannot select m2ts container in MC5888

Bug report and feature request
kawamoto76
Advanced
Advanced
Posts: 469
Joined: Sun Dec 14, 2008 4:52 pm
Location: JAPAN

cannot select m2ts container in MC5888

Postby kawamoto76 » Mon Apr 03, 2017 1:30 am

With 0.8.48 build 5888(64bit), when I will convert .ts file(mpeg2-aac) into x264-ac3, I cannot select M2TS for output container.
Mediacoder fails at the begining, telling error code 09, where MC tells it cannot mux intermediate product compornents(.264 and .ac3) with build-in multiplexer(TSmuxer V2). But, MPEG_TS container is allowed.
I can select M2TS output container when I use MC build 5865, but I cannot neither using build 5872, 5885, 5888. Why?
Ii might be derived from deploying buggy TSmuxeR 2.6.12 that I reported before in viewtopic.php?f=28&t=13649&p=40953#p40953.
Even with MC build 5865,because TSmuxeR 2.6.12 produce bad size product, I have to mux residual intermediate .264 and .ac3 manually with TSmuxeR ver1.10.6(smlabs) to get proper .m2ts file output, not using built-in muxer TSmuxeR 2.6.12.
Recent versions(5872, 5885, 5888) seems to avoid producing improper .m2ts output by built-in muxer TSmuxeR 2.6.12, rejecting at the entrance before conversion. This must be a secondary bug by introducing buggy TSmuxeR 2.6.12.
Akira Kawamoto
kawamoto76
Advanced
Advanced
Posts: 469
Joined: Sun Dec 14, 2008 4:52 pm
Location: JAPAN

Re: cannot select m2ts container in MC5888

Postby kawamoto76 » Mon Apr 03, 2017 2:45 am

Even with build 5865, because built-in muxer TSmuxeR 2.6.12 make bad size .m2ts output, I have to change TSmuxeR.exe and TSmuxerGUI.exe those are in tools mediacoder\tools holder into ver1.10.6(smlabs), or mux residual intermediate .264 and .ac3 manually with TSmuxeR ver1.10.6(smlabs).
Recent versions (5872, 5885, 5888) seems to reject MSTS output container setting before processing(encoding) not to produce bad .m2ts product. There I cannot get even intermediate .264 nor .ac3. Because I cannot get .m2ts with recent versions, this situation is worse than build 5865.
This must be a secondary bug by employing buggy TSmuxeR 2.6.12. Such bad rejecting is not nessesary when employing TSmuxeR ver1.10.6(smlabs)for the built-in muxer in Mediacoder.

I can bypass this bug, selecting FLV for outpit container,and muxing manually residual intermediate .264 and .ac3 with TSmuxeR ver1.10.6(smlabs) . Product .m2ts will be found in AVCHD structure by muxing.
Akira Kawamoto

Return to “Development”

Who is online

Users browsing this forum: No registered users and 9 guests