transcoding bug with MPEG2 video in M2TS container

Bug report and feature request
Post Reply
Posts: 3
Joined: Tue Apr 29, 2014 8:08 am

transcoding bug with MPEG2 video in M2TS container

Post by nelsonkidd » Tue Apr 29, 2014 9:53 am

I'm having problems creating an MPEG2 video in M2TS container.

At roughly 20 seconds, I start to hear audio and video glitches. At 25 seconds, I start to hear audio that I heard at the beginning of the file and video rendering is completely frozen. I'm using VLC 2.1.3 Rincewind for playback. I suppose it's plausible that VLC has the bug, but neither Win8's xbox video nor WindowsMediaPlayer apps seem to render MPEG2-TS container content, so it's difficult for me to blame VLC for the issue.

I am using MediaCoder Premium x64 Version 0.8.29 build 5608, Edition: vod

Here's a description of my preset.
[Video tab] VideoBitrate:20000 RateMode:CBR Format:MPEG2 Encoder:FFmpeg/Auto Source:MEncoder/Auto
[Audio tab] Format: AC-3 Bitrate:320kbps Encoder:FFmpeg/Auto Source:Default/Auto Resample:Original BitDepth:16
[Container] Container:M2TS Multiplexer:TSMuxer
[Picture] Resize:1920x1080 FrameRate:60.000 ColorSpace:I420 AspectRatio:KeepDisplayAR Crop:Disable Effects:SourceFilter

The input video file is freely available. It's the 2D/4K/60fps version of Big Buck Bunny, available here:

Starting with the broken preset, I tried some derivative presets that seem to work.
-Format=H.264 Encoder=x264/Auto Source=MEncoder/Auto, Multiplexer:TSMuxer
-Format=H.264 Encoder=x264/Auto Source=MEncoder/Auto, Multiplexer:FFmpeg
-Container:MPEG-TS, Multiplixer:FFmpeg
-Container:MPEG-TS, Multiplixer:TSMuxer

Starting with the broken preset, I also tried this derivative preset that immediately results in a MediaCoder error: 009
-Container:M2TS, Multiplixer:FFmpeg

I tried to upload the preset, but the website said .txt and .xml files were not permitted. Here is the preset in the message.

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="">AC-3</node><node key="">FFmpeg</node><node key="">1</node><node key="">1</node><node key="">CBR</node><node key="">20000</node><node key="">44</node><node key="">100</node><node key="">MPEG2</node><node key="">FFmpeg</node><node key="overall.container.format">M2TS</node><node key="overall.container.external">Enabled</node><node key="overall.container.muxer">TSMuxer</node><node key="overall.container.remuxer">7</node><node key="overall.preview.mode">Off</node><node key="audioenc.lame.bitrate">256</node><node key="audioenc.lame.stereo">Dual Channel</node><node key="audioenc.vorbis.mode">Bitrate</node><node key="audioenc.nero.quality">50</node><node key="audioenc.ffmpeg.bitrate">320</node><node key="videoenc.xvid.vhq">Wide Search</node><node key="videoenc.xvid.dx50">true</node><node key="videoenc.x264.profile">Main</node><node key="videoenc.x264.preset">Slow</node><node key="">High</node><node key="videoenc.vpxenc.quality">Best</node><node key="videoenc.ffmpeg.me_range">64</node><node key="videoenc.ffmpeg.bframes">1</node><node key="videoenc.ffmpeg.keyint">15</node><node key="muxer.mp4creator.hint">true</node><node key="muxer.mp4creator.optimize">true</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">1920</node><node key="videofilter.scale.height">1080</node><node key="videofilter.frame.enabled">true</node><node key="videofilter.frame.fps">60</node><node key="videofilter.denoise.lumaTemporal">12.000000</node><node key="videofilter.denoise.chromaTemporal">10.000000</node></MediaCoderPrefs>

Posts: 3116
Joined: Tue Jun 23, 2009 2:45 pm
Location: Sydney, Australia

Re: transcoding bug with MPEG2 video in M2TS container

Post by meRobs » Tue Apr 29, 2014 12:53 pm

I suggest you try the suggested settings for MPEG2 in the Encoding Guide, listed under Tips & Guides (link below).
Then, change the settings one at a time as you approach what you want.
Finally, report your findings
Have you checked out the Tips & Guides for MediaCoder? Try:
Also, get older builds at:

Post Reply