bframe parameters not used

Bug report and feature request
Post Reply
nodiaque
Amateur
Amateur
Posts: 16
Joined: Sat Aug 24, 2013 10:24 pm

bframe parameters not used

Post by nodiaque » Sun Jan 05, 2014 2:12 am

Hello,

the bframe parameters in x264 compression isn't used. Whatever you set it to, it doesn't appear in the advanced "video options" window and when checking the console, the x264 info screen clearly say bframe=5 whatever setting you put. I've tried with all rate mode and setting I can, they all does that.

Thanks

meRobs
Expert
Expert
Posts: 3116
Joined: Tue Jun 23, 2009 2:45 pm
Location: Sydney, Australia

Re: bframe parameters not used

Post by meRobs » Sun Jan 05, 2014 8:53 am

Please indicate the build of MediaCoder you are using, such as 5582 ...
Have you checked out the Tips & Guides for MediaCoder? Try: http://forum.mediacoderhq.com/viewtopic.php?f=17&t=8061
Also, get older builds at: http://www.videohelp.com/tools/MediaCoder/old-versions#download

stanley
Site Admin
Site Admin
Posts: 4123
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: bframe parameters not used

Post by stanley » Sun Jan 05, 2014 5:48 pm

Make sure you have set profile to main or high profile.
When things work together, things work.

nodiaque
Amateur
Amateur
Posts: 16
Joined: Sat Aug 24, 2013 10:24 pm

Re: bframe parameters not used

Post by nodiaque » Mon Jan 06, 2014 1:15 am

I'm on 5585. Using profile high10. If I set to High, the parameters appear in the command line. High10 should have the option too.

Also, in the command line, there's 2 time the --ref command. Changing the number of reference frame change both, so it's redundant.

I though using advanced mode, I could change the command line, but it doesn't work. Whatever parameters I change in the option, it won't be changed once ran.

stanley
Site Admin
Site Admin
Posts: 4123
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: bframe parameters not used

Post by stanley » Sat Jan 11, 2014 12:28 pm

Number of b-frame won't be bigger than ref + 1.
When things work together, things work.

Post Reply