x265 clips cause VLC to crash at their last second

Bug report and feature request
Post Reply
Yatsura
Amateur
Amateur
Posts: 15
Joined: Thu Dec 08, 2011 12:42 am

x265 clips cause VLC to crash at their last second

Post by Yatsura » Mon Jan 06, 2020 4:25 am

I want to create a short clip of 10-60 seconds out of a x265 movie but VLC cant properly play them.
There seems to be an pixel error at the end and VLC will crash in the last second of a clip.

Mediacoder sais the original movie codec is "V_MPEGH/ISO/HEVC". The movie tag sais its x265.
To create the clip I set Mediacoders video Format to h.265, Encoder to Auto (x265 is shown), Source to Auto (FFmpeg is shown) and Preset to Medium or Very Fast. On the Time tab I set a Start Position and End Position. If I use the Select button, the movie will not play and the preview screen will stay grey. Thats why I put in the time stamps manually.

So whats causing this? I am no expert, so if I forgot any more specific informations about anything, please dont hesitate to ask about them.

stanley
Site Admin
Site Admin
Posts: 4130
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: x265 clips cause VLC to crash at their last second

Post by stanley » Wed Feb 26, 2020 8:19 am

Which version are you using?
When things work together, things work.

Yatsura
Amateur
Amateur
Posts: 15
Joined: Thu Dec 08, 2011 12:42 am

Re: x265 clips cause VLC to crash at their last second

Post by Yatsura » Thu Mar 12, 2020 8:03 pm

It was the newest version available at the time (Dezember 2019). Probably 0.8.59.

It worked just fine with x265 preset "Ultra Fast" for whatever reason. Probably something about b-frames, i-frames or whatever gets changed in the preset settings and could cause display errors.

Post Reply