Page 1 of 5

Post your working "Presets" here

Posted: Sat Jan 10, 2009 4:57 pm
by mixer
MediaCoder Presets
Note: Since not all presets will work with all versions, make sure to use a preset compatible with your version of MediaCoder or edit it. The most current presets are at the end of this list.

(For more detailed information on using "Presets", see this: viewtopic.php?f=17&t=8131)

What is a preset?

A preset is a copy of your MediaCoder settings for a conversion. They can be saved by clicking "File" and then selecting "Save As Preset". A saved preset can then be loaded into MediaCoder. This a a great way to save a particular setup.


Posting a preset

A preset is in the form of an XML file. You must change the extension from XML to TXT, then you can edit, copy and paste the file as you would text into a post.

When posting a preset, please post them as a reply to this topic. Include some basic information such as:

1. What the preset is for. What it converts from and to?
2. Version/Build of MediaCoder.

This information is vital to correct operation, presets without this may be edited or deleted. See my example


Using a posted preset

Copy and paste the preset code to a location on your computer as a text (TXT) file. To do this:

1. Click, drag and highlight the preset code only.
2. Right click on the highlighted preset code and select "Copy"
3. Using Windows, find and start "Notepad" (or another text editor)
4. Using Notepad, right click in the empty box and select "Paste"
5. Using Notepad, click on "File" and select "Save As"
6. Note the location you'll be saving to and type in a name
7. Locate the saved preset TXT file on your computer and change the extension from TXT to XML.
8. Start MediaCoder and then click "File" and select "Revert All Settings"
9. Load the preset.xml file into MediaCoder by clicking on "File" and selecting "Load Preset"
10. Then, navigate to the location you saved the preset, and double click it.

Important Notes

Loading a preset may alter your "Output" and "Working" folders, so you may have to reset those.
Depending on the version of MediaCoder, some presets may not be totally compatible. You may be able to add the following line for compatibility:
<node key="overall.audio.autoEncoder" value="false"/>


Keyboard shortcuts for copy and paste:

CTRL+C same as mouse right click copy
CTRL+V same as mouse right click paste

Posted: Sat Jan 10, 2009 5:08 pm
by mixer
Here's one I use all the time for no compression, no loss editing. It does produce very large files. One nice feature is that about any video editing program (NLE) will accept AVI/Huffyuv/Waveform combination.

Build: 4242
From: Just about anything
To: AVI

Container: AVI
Video Codec(Format): Huffyuv
Bitrate Quality: 100%
Audio Codec(Encoder): Waveform
no other adjustments

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.mode" value="Advanced"/><node key="overall.ui.param" value="1217,640,175,117"/><node key="overall.ui.noWelcome" value="4242"/><node key="overall.task.destdir" value="D:\Temp\"/><node key="overall.task.tempdir" value="D:\Media\"/><node key="overall.audio.encoder" value="Waveform"/><node key="overall.video.mode" value="Quality-based"/><node key="overall.video.quality" value="100"/><node key="overall.video.format" value="Huffyuv"/><node key="overall.container.format" value="AVI"/><node key="videofilter.frame.enabled" value="false"/></MediaCoderPrefs>

Posted: Sat Jan 10, 2009 5:29 pm
by mixer
Here's one for converting just about any A/V file to a audio only MP3 with close to CD quality.

Build: 4242
From: Just about anything
To: MP3 audio only

Container: MP3
Bitrate: 192 kb/s
Audio Codec(Encoder): Lame MP3
no other adjustments


<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.mode" value="Advanced"/><node key="overall.ui.param" value="1217,640,175,117"/><node key="overall.ui.noWelcome" value="4242"/><node key="overall.task.destdir" value="D:\Temp\"/><node key="overall.task.tempdir" value="D:\Media\"/><node key="overall.video.enabled" value="false"/><node key="audioenc.lame.bitrate" value="192"/><node key="videofilter.frame.enabled" value="false"/></MediaCoderPrefs>

Posted: Sat Jan 10, 2009 8:35 pm
by Mike-RaWare
I use WMA lossless instead of any other lossless formats because its the only losslessly compressed format Windows can display information of.

Build: 4243
From: Any lossless audio format MediaCoder supports
To: WMA lossless (audio only)

Container: WMA
Bitrate: Lossless
Audio Codec (Encoder): WMA

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs>
	<node key="overall.audio.encoder" value="Windows Media Audio"/>
	<node key="overall.video.enabled" value="false"/>
	<node key="videoenc.wm.audioCodec" value="Windows Media Audio 9.2 Lossless"/>
	<node key="videoenc.wm.audioMode" value="Quality-Based VBR"/>
	<node key="videoenc.wm.audioFormat" value="VBR Quality 100, 44 kHz, 2 channel 16 bit VBR"/>
</MediaCoderPrefs>

Posted: Sun Jan 11, 2009 3:32 pm
by mixer
Used for playback in the Serato "Scratch Live/Video-SL" video for DJ's
(a big thanks to djjoshuacarl who came up with this)


Build: 4160 ?
From: Just about anything
To: MP4

Container: MP4
Video Codec(Format): H.264
Bitrate: 3500 kb/s
Audio Codec(Encoder): FAAC/AAC
Audio Bitrate: 160 kb/s
Many other settings

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.mode" value="Advanced"/><node key="overall.ui.optionTab" value="5"/><node key="overall.ui.param" value="807,713,876,216"/><node key="overall.ui.noWelcome" value="4106"/><node key="overall.task.destdir" value="D:\Temp\"/><node key="overall.task.tempdir" value="D:\Media\"/><node key="overall.audio.source" value="FFmpeg"/><node key="overall.audio.encoder" value="FAAC"/><node key="overall.video.mode" value="Two-Pass"/><node key="overall.video.bitrate" value="3500"/><node key="overall.video.quality" value="100"/><node key="overall.video.source" value="FFmpeg"/><node key="overall.video.encoder" value="x264"/><node key="overall.preview.render" value="false"/><node key="audioenc.faac.mode" value="Bitrate"/><node key="audioenc.faac.bitrate" value="160"/><node key="videoenc.x264.profile" value="Baseline"/><node key="videoenc.x264.level" value="30"/><node key="videoenc.x264.keyint" value="12"/><node key="videoenc.x264.keyint_min" value="12"/><node key="videoenc.mencoder.options" value="-deinterlace"/><node key="videoenc.ffmpeg.keyint" value="12"/><node key="videoenc.ffmpeg.options" value="-deinterlace"/><node key="audiofilter.resample.samplerate" value="48000"/><node key="audiofilter.volume.clipping" value="true"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="640"/><node key="videofilter.scale.height" value="480"/><node key="videofilter.frame.fps" value="30000"/><node key="videofilter.frame.fpsScale" value="1001"/><node key="videofilter.eq.contrast" value="60"/><node key="videofilter.eq.saturation" value="120"/><node key="videofilter.postproc.deint" value="YADIF mode 0"/></MediaCoderPrefs>

Posted: Mon Jan 12, 2009 5:45 am
by Steerpike
Purpose - convert various digital camera videos to iPhone/iPod.

Build/Version: 0.6.2.4242
From: Just about anything
To: MP4

Container: MP4
Video Codec(Format): H.264
Bitrate: 1024 kb/s
Audio Codec(Encoder): FAAC/AAC
Audio Bitrate: 128 kb/s
Video Size: 640x368



<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab" value="5"/><node key="overall.audio.encoder" value="FAAC"/><node key="overall.video.bitrate" value="1024"/><node key="overall.preview.render" value="false"/><node key="audioenc.faac.mode" value="Bitrate"/><node key="videoenc.x264.profile" value="Baseline"/><node key="videoenc.x264.level" value="30"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="640"/><node key="videofilter.scale.height" value="368"/></MediaCoderPrefs>

Note, I've tried different rates for bitrates (audio and video) - you can adjust them to taste. Also the 'scale' (and the aspect ratio) can be modified to suite your input media format. Just about the only 'hard requirement' is to set 'baseline level 3' in the h.264 setting.

Tested with an AVI from my Canon S45, and a .MOV from my Lumix LX3.

Re: Post your working "Presets" here

Posted: Wed Apr 08, 2009 8:50 pm
by kmrdeva
1. I use this preset to convert videos for playback on my phone, a Nokia 5800 XPressMusic.
2. I normally convert downloaded xvid AVIs to h264 MP4s.
3. I am using Mediacode Portable 0.6.2.4275 on a Windows XP SP3 computer.

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs>
<node key="overall.generic.priority" value="Normal"/>
<node key="overall.generic.autoRevert" value="Always"/>
<node key="overall.ui.mode" value="Advanced"/>
<node key="overall.ui.language" value="1"/>
<node key="overall.ui.browserMode" value="App Mode"/>
<node key="overall.ui.optionTab" value="3"/>
<node key="overall.ui.param" value="676,728,318,52"/>
<node key="overall.ui.noWelcome" value="4255"/>
<node key="overall.task.destdir" value="C:\"/>
<node key="overall.tagging.tag" value="false"/>
<node key="overall.tagging.formatting" value="true"/>
<node key="overall.tagging.fileNameFormat" value="$(SourceFileName)_transcoded"/>
<node key="overall.subtitle.slang" value="en"/>
<node key="overall.subtitle.font" value="C:\WINDOWS\Fonts\simhei.ttf"/>
<node key="overall.audio.channels" value="Original"/>
<node key="overall.audio.encoder" value="Nero Encoder"/>
<node key="overall.video.bitrate" value="768"/>
<node key="overall.video.darw" value="4"/>
<node key="overall.video.darh" value="3"/>
<node key="overall.preview.render" value="false"/>
<node key="audioenc.nero.format" value="LC-AAC"/>
<node key="audioenc.nero.mode" value="Target Bitrate"/>
<node key="audioenc.nero.bitrate" value="128"/>
<node key="videoenc.xvid.profile" value="Advanced Simple Profile Level 5"/>
<node key="videoenc.x264.profile" value="Baseline"/>
<node key="videoenc.x264.level" value="20"/>
<node key="audiofilter.volume.gain" value="6.000000"/>
<node key="videofilter.scale.enabled" value="true"/>
<node key="videofilter.scale.width" value="352"/>
<node key="videofilter.scale.height" value="240"/>
<node key="videofilter.scale.scaleDown" value="true"/>
</MediaCoderPrefs>

Re: Post your working "Presets" here

Posted: Mon May 04, 2009 10:00 am
by Nighthawk1
Unknown version/build (please update)

I am a newbie also but have been playing around with Mediacoder for a little while to convert MKV files. Here is the "best" presets I have found: (will be in MPEG2 format though, works for me! Compression is good!)
Video: Enable Video, Format = MPEG2, Mode = Bitrate-based 5000kbps
Audio: Enable Audio, Source = Auto Select, Encoder = FFmpeg (copy audio unchecked), leave rest as default
Container = default
Picture: Resize = Original, Crop = Disabled, Frame Rate = Original
Sound = Stereo
Demuxer = default
Subtitle = Disabled (unless you want them)
Time = Set this for any approx 2 min part of file (just for testing until you are sure settings will work for you, then when ready to transcode full file = all 00's)
Text = All off
All else is default

Preset:
<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.browserMode" value="App Mode"/><node key="overall.ui.optionTab" value="7"/><node key="overall.ui.param" value="680,640,500,205"/><node key="overall.task.destdir" value="M:\My Movies\"/><node key="overall.tagging.tag" value="false"/><node key="overall.subtitle.mode" value="Disabled"/><node key="overall.audio.encoder" value="FFmpeg"/><node key="overall.video.bitrate" value="5000"/><node key="overall.video.darw" value="16"/><node key="overall.video.darh" value="9"/><node key="overall.video.format" value="MPEG2"/><node key="overall.container.format" value="Default"/><node key="overall.container.external" value="Disabled"/><node key="overall.preview.render" value="false"/><node key="audioenc.ffmpeg.codec" value="MP3"/><node key="audioenc.ffmpeg.bitrate" value="192"/><node key="videoenc.mencoder.mpegType" value="DVD"/><node key="videoenc.ffmpeg.me_range" value="64"/><node key="videoenc.ffmpeg.bframes" value="1"/><node key="videoenc.ffmpeg.keyint" value="75"/><node key="videoenc.ffmpeg.vrcMinRate" value="2000"/><node key="videoenc.ffmpeg.vrcMaxRate" value="9800"/><node key="videoenc.ffmpeg.vrcBufSize" value="1835"/><node key="videoenc.ffmpeg.format" value="dvd"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="720"/><node key="videofilter.scale.height" value="480"/><node key="videofilter.frame.enabled" value="true"/></MediaCoderPrefs>

Re: Post your working "Presets" here

Posted: Thu May 28, 2009 2:20 am
by misterhatoola
hi.
after long days of testing and re-testing, this is my preset for best-looking videos on my Sony Ericsson W760i.
according to sony ericsson's specs, it'll also work with their C510, C702, C901, C902, C903, C905, G502, G700, G705, G900, K660, K770, K790, K800, K810, K850, M600, P1, P990, S500, T650, T700, T707, W508, W580, W595, W705, W715, W760, W830, W850, W880, W890, W900, W902, W910, W950, W960, W980, W995, Z750, Z770, Z780.
it's an MP4-contained XVID with nero's AAC. I haven't used H.264, since it seems that the device doesn't like playing these files on hi-res (320x240) with high bitrates (over 150kbps), so you get better-looking videos with no lag with MPEG4 without AVC.
I've used ffmpeg for both multiplexing and remuxing; using mp4box doesn't allow the device to recognize the video file, and not enabling remux causes horrible sync/no sound problems. a mound of frustration there.
apparently the device doesn't like b-frames, GMC or quarter pixels; according to the spec MPEG4 Visual Simple profile should be used.
you can play with the quality sliders of both the video and the audio, and of course change it into bitrate-based.
have fun.

mediacoder 0.7.0-rc build 4390

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.audio.encoder" value="Nero Encoder"/><node key="overall.video.mode" value="Quality-based"/><node key="overall.video.bitrate" value="300"/><node key="overall.video.quality" value="70"/><node key="overall.video.format" value="XviD"/><node key="overall.video.autoEncoder" value="false"/><node key="overall.video.encoder" value="XviD"/><node key="overall.container.external" value="Enabled"/><node key="overall.container.muxer" value="FFmpeg"/><node key="overall.container.remux" value="true"/><node key="overall.container.remuxer" value="4"/><node key="overall.preview.render" value="false"/><node key="audioenc.lame.stereo" value="Joint Stereo"/><node key="audioenc.nero.format" value="LC-AAC"/><node key="audioenc.nero.quality" value="30"/><node key="audioenc.nero.bitrate" value="96"/><node key="audioenc.ffmpeg.codec" value="AAC"/><node key="videoenc.xvid.profile" value="Simple Profile Level 3"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="320"/><node key="videofilter.scale.height" value="240"/><node key="videofilter.scale.scaleDown" value="true"/></MediaCoderPrefs>

Re: Post your working "Presets" here

Posted: Sat Jun 27, 2009 12:35 pm
by kehn
My preset profile for PMP like ONDA VX 767:

Unknown version/build (please update)


Image

- Fixed file size:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.generic.autoRevert" value="Always"/><node key="overall.ui.browserMode" value="App Mode"/><node key="overall.ui.optionTab" value="2"/><node key="overall.ui.param" value="680,641,430,88"/><node key="overall.ui.noWelcome" value="4280"/><node key="overall.task.destdir" value="D:\NEW 767\"/><node key="overall.task.tempdir" value="C:\Program Files (x86)\MediaCoder\"/><node key="overall.subtitle.slang" value="en"/><node key="overall.subtitle.font" value="C:\Program Files (x86)\Vietkey\ARIALBD.TTF"/><node key="overall.subtitle.scale" value="4"/><node key="overall.subtitle.blur" value="7"/><node key="overall.subtitle.outline" value="4"/><node key="overall.video.quality" value="100"/><node key="overall.video.targetSize" value="999999"/><node key="overall.video.format" value="XviD"/><node key="overall.video.autoEncoder" value="false"/><node key="overall.container.format" value="AVI"/><node key="overall.preview.render" value="false"/><node key="overall.plugin.dir" value="plugins64/"/><node key="audiosrc.winamp.dir" value="plugins64/"/><node key="audioenc.lame.stereo" value="Dual Channel"/><node key="audioenc.lame.path" value=".\codecs\lame64.exe"/><node key="audioenc.fraunhofer.path" value=".\codecs\mp3sEncoder64.exe"/><node key="audioenc.musepack.path" value=".\codecs\mpcenc64.exe"/><node key="audioenc.ffmpeg.codec" value="AAC"/><node key="audioenc.ffmpeg.bitrate" value="96"/><node key="audioenc.aac3gpp.path" value=".\codecs\enhAacPlusEnc64.exe"/><node key="audioenc.wavpack.path" value=".\codecs\wavpack64.exe"/><node key="audioenc.wavpack.decoderPath" value=".\codecs\wvunpack64.exe"/><node key="audioenc.flac.path" value=".\codecs\flac64.exe"/><node key="audioenc.ape.path" value=".\codecs\MACDll64.dll"/><node key="videosrc.jm.path" value=".\codecs\ldecod64.exe"/><node key="videoenc.jm.path" value=".\codecs\lencod64.exe"/><node key="videoenc.wm.path" value=".\codecs\wmcodec64.exe"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="368"/><node key="videofilter.scale.height" value="208"/><node key="videofilter.frame.enabled" value="true"/><node key="videofilter.frame.fps" value="24000"/><node key="videofilter.frame.fpsScale" value="1001"/></MediaCoderPrefs>
- Fixed bitrate:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.generic.autoRevert" value="Always"/><node key="overall.ui.browserMode" value="App Mode"/><node key="overall.ui.optionTab" value="1"/><node key="overall.ui.param" value="680,640,446,71"/><node key="overall.ui.noWelcome" value="4388"/><node key="overall.task.destdir" value="D:\NEW 767\"/><node key="overall.task.tempdir" value="C:\Users\nguyendanhnguyen\"/><node key="overall.subtitle.slang" value="en"/><node key="overall.subtitle.font" value="C:\Program Files (x86)\Vietkey\ARIALBD.TTF"/><node key="overall.subtitle.scale" value="4"/><node key="overall.subtitle.blur" value="7"/><node key="overall.subtitle.outline" value="4"/><node key="overall.video.bitrate" value="999"/><node key="overall.video.quality" value="100"/><node key="overall.video.format" value="XviD"/><node key="overall.video.autoEncoder" value="false"/><node key="overall.container.format" value="AVI"/><node key="overall.preview.render" value="false"/><node key="overall.plugin.dir" value="plugins64/"/><node key="audiosrc.winamp.dir" value="plugins64/"/><node key="audioenc.lame.stereo" value="Dual Channel"/><node key="audioenc.lame.path" value=".\codecs\lame64.exe"/><node key="audioenc.fraunhofer.path" value=".\codecs\mp3sEncoder64.exe"/><node key="audioenc.musepack.path" value=".\codecs\mpcenc64.exe"/><node key="audioenc.ffmpeg.codec" value="AAC"/><node key="audioenc.ffmpeg.bitrate" value="96"/><node key="audioenc.aac3gpp.path" value=".\codecs\enhAacPlusEnc64.exe"/><node key="audioenc.wavpack.path" value=".\codecs\wavpack64.exe"/><node key="audioenc.wavpack.decoderPath" value=".\codecs\wvunpack64.exe"/><node key="audioenc.flac.path" value=".\codecs\flac64.exe"/><node key="audioenc.ape.path" value=".\codecs\MACDll64.dll"/><node key="videosrc.jm.path" value=".\codecs\ldecod64.exe"/><node key="videoenc.x264.path" value=".\codecs\x264_x64.exe"/><node key="videoenc.jm.path" value=".\codecs\lencod64.exe"/><node key="videoenc.wm.path" value=".\codecs\wmcodec64.exe"/><node key="videofilter.scale.enabled" value="true"/><node key="videofilter.scale.width" value="368"/><node key="videofilter.scale.height" value="208"/><node key="videofilter.frame.enabled" value="true"/></MediaCoderPrefs>
Hope that somebody will check it on other devices.