Post your working "Presets" here

Discuss about generic usage of MediaCoder.

Moderator: HuggiL

krisandrews
Beginner
Beginner
Posts: 4
Joined: Tue Dec 22, 2009 7:56 am

Re: Post your working "Presets" here

Postby krisandrews » Fri Dec 25, 2009 10:06 am

0.7.2 build 4536
Repost of my Xbox 360 presets..

I have found some settings that work fine for playing content on the Xbox 360.
I have attached pre-set files for both H.264 and DivX.

I have experimented a bit with the DivX settings, for audio VBR, ABR and CBR all work OK. The video is pre-set for a good quality DVD transcode at full size.
The only thing I have to change sometimes is the Aspect Ratio in Picture settings, sometimes it works best set to 16:9, and sometimes with no change.

If you want to test it select 30 seconds of your movie in the Time settings and transcode first before doing the whole film!

Using the AVI pre-set I get around 20 fps speed on a 3.2GHz P4.

Let me know how you get on with these...

P.S. Not sure if you can transcode copy protected DVDs using Mediacoder, I normally use DVD Decrypter to get it onto my hard drive first!

To use, copy into a text file and save as <preset name>.xml

File xboxavi.xml

Code: Select all

    <?xml version="1.0" encoding="UTF-8"?>
    <MediaCoderPrefs><node key="overall.ui.mode">Advanced</node><node key="overall.ui.expertView">Audio Command</node><node key="overall.ui.optionTab">7</node><node key="overall.ui.param">680,717,92,46</node><node key="overall.task.destdir">C:\Documents and Settings\Kristian\My Documents\My Videos\</node><node key="overall.video.mode">Quality-based</node><node key="overall.video.quality">90</node><node key="overall.video.dar">true</node><node key="overall.video.darw">16</node><node key="overall.video.darh">9</node><node key="overall.video.format">XviD</node><node key="overall.container.format">AVI</node><node key="overall.playback.render">false</node><node key="audioenc.lame.mode">ABR</node><node key="videoenc.xvid.dx50">true</node><node key="audiofilter.resample.samplerate">44100</node><node key="videofilter.frame.enabled">false</node></MediaCoderPrefs>
File xbox360h264.xml

Code: Select all

    <?xml version="1.0" encoding="UTF-8"?>
    <MediaCoderPrefs><node key="overall.ui.mode">Advanced</node><node key="overall.ui.expertView">Audio Command</node><node key="overall.ui.param">680,640,352,104</node><node key="overall.task.destdir">C:\Documents and Settings\Kristian\My Documents\My Videos\</node><node key="overall.audio.encoder">Nero Encoder</node><node key="overall.video.mode">Quality-based</node><node key="overall.video.quality">60</node><node key="overall.video.dar">true</node><node key="overall.video.darw">16</node><node key="overall.video.darh">9</node><node key="overall.playback.render">false</node><node key="audioenc.aacplus.type">LC-AAC</node><node key="audioenc.nero.format">LC-AAC</node><node key="audioenc.nero.mode">Target Bitrate</node><node key="audioenc.nero.bitrate">128</node><node key="videofilter.frame.enabled">false</node></MediaCoderPrefs>
dtechnology
Amateur
Amateur
Posts: 22
Joined: Tue Jan 19, 2010 8:55 pm

Re: Post your working "Presets" here

Postby dtechnology » Wed Jan 27, 2010 9:31 pm

My HTC Touch Diamond preset.

Don't know if the HTC Diamond plays it natively, but the Diamond 2 (with 99% the same hardware) does.

I've confirmed that both of these play the files smooth and natively.
I mainly encode on 96 Kbit/s audio to save space. You can increase is without problem to 128 kbit/s (e.g. for music video's). In my experience 192 kbit/s or 256 kbit/s is also no problem, as long as you lower the video bitrate a bit.

Specs:
Mediacoder version: 0.7.2.4569 (both x86 and x64)
Video: H.264 (x264 or CUDA) Baseline Level 3.0 256 Kbit/s (increase up to 384 should be save, but expect minor lagging. 512 Kbit/s will also usually work, but expect a little-less-minor lagging)
Audio: LC-AAC ABR 96 kbit/s (I prefer Nero encoder)
Resolution: 640x480
Encoding Mode: 2-Pass (because of the low resolution and bitrate I strongly advice to encode 2-Pass. It increases quality greatly while costing relatively little time at these bitrates/resolutions)

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs>
	<node key="overall.audio.channels">Original</node>
	<node key="overall.audio.encoder">Nero Encoder</node>
	<node key="overall.video.mode">2-Pass</node>
	<node key="overall.video.bitrate">256</node>
	<node key="audioenc.nero.format">LC-AAC</node>
	<node key="audioenc.nero.mode">Target Bitrate</node>
	<node key="audioenc.nero.bitrate">96</node>
	<node key="videoenc.x264.profile">Baseline</node>
	<node key="videoenc.x264.level">30</node>
	<node key="videoenc.cuda264.level">30</node>
	<node key="videoenc.cuda264.bframes">0</node>
	<node key="videofilter.scale.width">640</node>
	<node key="videofilter.scale.height">480</node>
</MediaCoderPrefs>
If you cannot get a file to play back smooth, want to save space or are just happy with a lower resolution. You can also use the 320x240 resolution. The same bitrate does mean more detail at this low resolution, so a 256 Kbit/s bitrate is (while low for 640x480) perfectly fine for 320x240. And you can also use 128 Kbit/s or 192 Kbit/s.

Specs:
Video: H.264 (x264 or CUDA) Baseline Level 1.3 256 Kbit/s (decrease up to 128 Kbit is possible, at the cost of quality)
Audio: LC-AAC ABR 96 Kbit/s (I prefer Nero encoder)
Resolution: 320x240
Encoding Mode: 2-Pass (because of the low resolution and bitrate I strongly advice to encode 2-Pass. It increases quality greatly while costing relatively little time at these bitrates/resolutions)

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs>
	<node key="overall.audio.channels">Original</node>
	<node key="overall.audio.encoder">Nero Encoder</node>
	<node key="overall.video.mode">2-Pass</node>
	<node key="overall.video.bitrate">256</node>
	<node key="audioenc.nero.format">LC-AAC</node>
	<node key="audioenc.nero.mode">Target Bitrate</node>
	<node key="audioenc.nero.bitrate">96</node>
	<node key="videoenc.x264.profile">Baseline</node>
	<node key="videoenc.x264.level">13</node>
	<node key="videoenc.cuda264.level">13</node>
	<node key="videoenc.cuda264.bframes">0</node>
	<node key="videofilter.scale.width"320</node>
	<node key="videofilter.scale.height">240</node>
</MediaCoderPrefs>
Note: There are also so called "Custom ROM's" (I personally prefer this one for it's stability, speed and multilanguage) that bring the diamond2 software to the diamond (or even newer software, like the HTC HD2's. Personally I find the so called Sense software to slow and laggy on the diamond, remember that the HD2 has a more than twice as fast processor and much more RAM).
User avatar
vasquuez
Amateur
Amateur
Posts: 19
Joined: Tue Feb 13, 2007 1:14 am
Location: Poland

Re: Post your working "Presets" here

Postby vasquuez » Fri Feb 19, 2010 3:59 am

AVI (h264 + mp3)


Version: 0.7.3 Build 4602
From: Any video format possible
To: AVI

Container: AVI
Multiplexer: Disabled

Video
Format: H.264
Mode: 2-pass
Bitrate: 450Kbps
Source: AUTO
Encoder: MEncoder
Profile: Auto
Level: Auto
Preset: Very Fast
Tune: Normal

Audio
Encoder: Helix Mp3
Format: Mp3
Source: Auto
Resample: Original
Bitrate: 100Kbps VBR

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">1</node><node key="overall.ui.noWelcome">4602</node><node key="overall.audio.format">MP3</node><node key="overall.audio.encoder">Helix MP3</node><node key="overall.video.mode">2-Pass</node><node key="overall.video.bitrate">450</node><node key="overall.video.source">MPlayer</node><node key="overall.video.autoEncoder">false</node><node key="overall.video.encoder">MEncoder</node><node key="overall.container.format">AVI</node><node key="overall.container.external">Disabled</node><node key="overall.container.muxer">MEncoder</node><node key="overall.playback.render">false</node><node key="audioenc.lame.bitrate">100</node><node key="audioenc.lame.mode">ABR</node><node key="audioenc.helixmp3.bitrate">100</node><node key="videoenc.x264.preset">Very Fast</node></MediaCoderPrefs>
nuhkka
Beginner
Beginner
Posts: 7
Joined: Thu Jan 07, 2010 10:43 am

Re: Post your working "Presets" here

Postby nuhkka » Mon Apr 05, 2010 8:59 am

Sansa Fuze

Mediacoder 0.7.3.4616

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">4</node><node key="overall.ui.param">1270,979,6,5</node><node key="overall.ui.noWelcome">4550</node><node key="overall.task.destdir">C:\Users\Rob\Downloads\</node><node key="overall.audio.format">MP3</node><node key="overall.audio.encoder">LAME MP3</node><node key="overall.video.mode">2-Pass</node><node key="overall.video.bitrate">400</node><node key="overall.video.ar">Set DAR</node><node key="overall.video.arNum">14</node><node key="overall.video.arDen">11</node><node key="overall.video.format">MPEG4</node><node key="overall.video.autoEncoder">false</node><node key="overall.video.encoder">MEncoder</node><node key="overall.container.format">AVI</node><node key="audioenc.lame.stereo">Joint Stereo</node><node key="audiofilter.resample.samplerate">44100</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">224</node><node key="videofilter.scale.height">176</node><node key="videofilter.crop.mode">Expand to fit</node><node key="videofilter.frame.enabled">true</node><node key="videofilter.frame.fps">20</node></MediaCoderPrefs>
barochallo
Beginner
Beginner
Posts: 4
Joined: Wed Apr 07, 2010 12:31 am

Preset for video conversion for Nokia 5800 Xpress Music

Postby barochallo » Thu Apr 08, 2010 12:00 am

Hello mates,

Here's my working preset for converting videos for Nokia 5800 Xpress Music mobile phone in MPEG4 format. The output quality is beautiful. Try it out.

Build: 0.7.2.4582
From: Just about anything
To: MP4

Container: MP4
Video Codec (Format): MPEG4
Bitrate: 800 kbps
Audio Codec (Encoder): FAAC/ AAC
Audio Bitrate: 100 kbps

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">2</node><node key="overall.ui.param">700,640,275,26</node><node key="overall.ui.noWelcome">4582</node><node key="overall.task.destdir">C:\Users\Pranav\Desktop\</node><node key="overall.video.bitrate">800</node><node key="overall.video.ar">Set DAR</node><node key="overall.video.arNum">16</node><node key="overall.video.arDen">9</node><node key="overall.video.format">MPEG4</node><node key="overall.playback.render">false</node><node key="audioenc.faac.mode">Bitrate</node><node key="audioenc.faac.quality">128</node><node key="audioenc.faac.bitrate">100</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">640</node><node key="videofilter.scale.height">360</node></MediaCoderPrefs>
I take no credit for the above. It's a permutation and combination of a number of presets I found on the Internet. Thanks to all the original uploaders of the same.


UPDATE

I had also been hunting all over the Internet looking for means to encode movies into H.264 for my Nokia 5800 Xpress Music. I played around with the settings on Mediacoder (0.7.2.4582) and finally came up with a preset, using the Format H.264-Encoder Xvid, that actually works!

To give an idea about the compression, I transcoded an 742 MB AVI file into an H.264 -encoded MP4 file sized 727 MB (I know that's not too much, but the quality appears to be better than the 758 MB MPEG4 encoded file of the same movie) :


Build: 0.7.2.4582
From: Just about anything
To: MP4 (H.264/AAC)

Container: MP4
Video Codec (Format): H.264
Bitrate: 800 kbps Actually I try to keep the video bitrate the same as the source file. I believe that one can't output a video with a bitrate that is more than that of the source file. Or am I wrong?? (that may be just my ignorant newbie opinion!)
Audio Codec (Encoder): FAAC/ AAC
Audio Bitrate: 100 kbps (I tried reducing the bit rate but the quality deteriorated considerably)

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.generic.ignoredBuild">4616</node><node key="overall.ui.optionTab">1</node><node key="overall.ui.param">776,714,354,19</node><node key="overall.ui.noWelcome">4582</node><node key="overall.task.destdir">C:\Users\Pranav\Desktop\MP4 Files\</node><node key="overall.video.bitrate">780</node><node key="overall.video.autoEncoder">false</node><node key="overall.video.encoder">XviD</node><node key="overall.playback.render">false</node><node key="audioenc.faac.mode">Bitrate</node><node key="audioenc.faac.bitrate">100</node><node key="videoenc.x264.profile">Baseline</node><node key="videoenc.x264.level">30</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">640</node><node key="videofilter.scale.height">360</node></MediaCoderPrefs>
Please remember NOT to check the 'Auto select' box next to the Encoder-XviD in the video settings. I did that once by mistake and my phone did not read the file.

***N.B. Please remember to change the output folder!

Now I prefer the H.264 transcoding to the MPEG4 type :)
Any other tips/ suggestions/ feedback most welcome!

I will be encoding a video using a H.264 bitrate of 400 and 800 and comparing the quality. I will update this post with the results. 8)

regards,
barochallo
xrave
Beginner
Beginner
Posts: 4
Joined: Sat Dec 26, 2009 5:28 pm

XBOX 360 Preset

Postby xrave » Mon Jul 26, 2010 5:23 am

This preset i use to convert MKV to MP4 to play on my xbox 360

Using version 0.7.5.4703


<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.mode">Advanced</node><node key="overall.ui.optionTab">1</node><node key="overall.ui.param">700,640,370,130</node><node key="overall.task.destdir">E:\Converted\</node><node key="overall.subtitle.pos">93</node><node key="overall.subtitle.scale">2</node><node key="overall.audio.channels">Original</node><node key="overall.audio.autoSource">false</node><node key="overall.audio.source">MEncoder</node><node key="overall.audio.format">LC-AAC</node><node key="overall.audio.encoder">FAAC</node><node key="overall.video.bitrate">1628</node><node key="overall.video.quality">16</node><node key="videofilter.scale.enabled">true</node></MediaCoderPrefs>
marjamar
Amateur
Amateur
Posts: 20
Joined: Mon Jul 05, 2010 3:54 am

Working preset for Blu-Ray to HD using CUDA

Postby marjamar » Thu Jul 29, 2010 12:03 am

Hello people,

I was asked to post my "Preset" for Blu-Ray conversion to 1920x1080HD. I struggled quite a while trying to make this work using my CPU for to transcode, but it never completed the full feature. After exhausting all other options (and settings in Mediacoder), I decided to purchase a new CUDA based video card and try transcoding using the cards GPU instead of my computers CPU. Suspecting there may be issues with codec's and codec packs installed on this system (which do what I intended them to), and not wanting to change my systems software setups just to accommodate Blu-Ray conversions, I though I'd try going the CUDA route instead.

Looking over the various cards available, I decided to go all out and purchased next to the top of the line out there. Overall, I am very pleased with my decision and I now have a fully workable solution that transcodes (so far) every Blu-Ray disc I've tried.

Using about stock settings (no internal tweaks to codec parameters), I am very happy with the output I'm getting as I wanted at or nearly identical apparent quality, at a maximum file size of around 8GB or so, while keeping 5.1 Dolby sound. This is very doable based on my eyes and ears, and so far to everyone else who has watched these transcoded Blu-Ray titles.

So, if you are wanting to try to get Blu-Ray quality on your HD, without the excessive file size that comes along with BD, here's the preset to use. Obviously, tweaking can be done (for better or worse), but using this preset as is, should provide you with a very nice HD movie that I think most of us would consider Blu-Ray HD quality.

P.s. - Obviously, Blu-Ray discs are copy protected and since I do not wish to get into any debate on "fair use" issues which I'm sure are or could be a major stumbling block depending on where you live, I just mention that you will need to have non-copy protected content for any of this to work.

Here's my preset. Hope it helps some of you to enjoy your Blu-Ray titles even more then you do now.


-Rodger

Edit: I was asked to be a little more specific as to build number, hardware, and as I see in some proceeding posts on this topic, a brief profile description of transcode settings. So, here's some of that info -

SOFTWARE
MediaCoder 64Bit Version
Build: 0.7.5 build 4703
From: Blu-Ray Media
To: 1920x1080 24p HD
Container: Matroska
Muxer: FFmpeg
Video: H.264
Encoder: CUDA Encoder (x264)
Mode: Constant Bitrate
Bitrate: 12,000 Kbps
Frame Rate: 23.98 FPS
De-interlace: Auto
Audio: LC-AAC
Encoder: FAAC
Bitrate: 128 Kbps
Audio Container: MP4
Sample Rate: 48 Khz
Channels: 5.1 (Dolby)

COMPUTER HARDWARE
Manufacturer: Hewlett Packard
Product: M7640N
Processor: AMD Athlon 64 X2 2.6 GHz
Chipset: NVIDIA GeForce 6150 LE
Installed Memory: 4 GB (DDR2 SDRAM)
Operating System: Microsoft Windows 7 64 Bit

VIDEO HARDWARE
Manufacturer: PNY
Product: nVidia GeForce GTX 480
Core Clock: 700 MHz
Processor Cores: 480
Processor Clock: 1401 MHz
Texture Fill Rate: 42.0 Billion/sec.
Memory Amount: 1536MB GDDR5
Memory Data Rate, effective: 3696 MHz
Memory Interface: 384-bit
Memory Bandwidth: 177.4 GB/sec.
On-board Outputs: DVI-I, DVI-I, and Mini HDMI
Additional Outputs Supported: VGA
Bus Type: PCI Express® 2.0

BLU-RAY TO 1920X1080, 24P, 5.1 DOLBY

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.mode">Advanced</node><node key="overall.ui.expertView">Audio Command</node><node key="overall.ui.optionTab">2</node><node key="overall.ui.param">1113,717,1,0</node><node key="overall.ui.noWelcome">4685</node><node key="overall.task.destdir">K:\Mediacoder Transcodes\</node><node key="overall.audio.channels">5.1 Channels</node><node key="overall.audio.format">LC-AAC</node><node key="overall.audio.encoder">FAAC</node><node key="overall.video.mode">CBR</node><node key="overall.video.bitrate">12000</node><node key="overall.video.quality">100</node><node key="overall.video.autoSource">false</node><node key="overall.video.source">FFmpeg</node><node key="overall.video.autoEncoder">false</node><node key="overall.video.encoder">CUDA Encoder</node><node key="overall.container.format">Matroska</node><node key="overall.container.external">Enabled</node><node key="overall.container.muxer">FFmpeg</node><node key="overall.playback.render">false</node><node key="overall.plugin.dir">plugins64/</node><node key="audiosrc.winamp.dir">plugins64/</node><node key="audioenc.lame.preset">CD (ABR/192Kbps)</node><node key="audioenc.lame.path">.\codecs\lame64.exe</node><node key="audioenc.vorbis.path">.\codecs\oggenc64.exe</node><node key="audioenc.faac.quality">128</node><node key="audioenc.faac.container">MP4</node><node key="audioenc.aacplus.bitrate">128</node><node key="audioenc.aacplus.mode">Stereo</node><node key="audioenc.aacplus.type">LC-AAC</node><node key="audioenc.fraunhofer.path">.\codecs\mp3sEncoder64.exe</node><node key="audioenc.musepack.path">.\codecs\mpcenc64.exe</node><node key="audioenc.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="audioenc.aac3gpp.path">.\codecs\enhAacPlusEnc64.exe</node><node key="audioenc.wavpack.path">.\codecs\wavpack64.exe</node><node key="audioenc.wavpack.decoderPath">.\codecs\wvunpack64.exe</node><node key="audioenc.flac.path">.\codecs\flac64.exe</node><node key="audioenc.ape.path">.\codecs\MACDll64.dll</node><node key="videosrc.mencoder.coreavc">true</node><node key="videosrc.jm.path">.\codecs\ldecod64.exe</node><node key="videoenc.xvid.path">.\codecs\xvidcore64.dll</node><node key="videoenc.x264.profile">High</node><node key="videoenc.x264.level">40</node><node key="videoenc.x264.path">.\codecs\x264_64.exe</node><node key="videoenc.cuda264.profile">High</node><node key="videoenc.cuda264.preset">AVCHD</node><node key="videoenc.cuda264.gop">true</node><node key="videoenc.cuda264.path">.\codecs\cudaH264Enc64.exe</node><node key="videoenc.jm.path">.\codecs\lencod64.exe</node><node key="videoenc.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="videoenc.theora.path">.\codecs\theora_encoder_64.exe</node><node key="videoenc.wm.path">.\codecs\wmcodec64.exe</node><node key="audiofilter.resample.samplerate">48000</node><node key="videofilter.frame.enabled">true</node><node key="videofilter.frame.fps">24000</node><node key="videofilter.frame.fpsScale">1001</node></MediaCoderPrefs>
Mosco
Amateur
Amateur
Posts: 13
Joined: Wed Sep 29, 2010 5:23 pm
Location: Italy

Majestic DS 63/4G Mp4 Player

Postby Mosco » Fri Nov 05, 2010 1:46 am

Hi mates. This is my working preset for any type of video file that can be played on this mp4 mini player.

Build/Version:Mediacoder Full Edition 0.7.5.4742
From: Just about anything
To: Xvid/mp4 Avi file

Container: AVI
Video Codec(Format): Xvid
Bitrate: 512 kb/s
Audio Codec(Encoder): FFmpeg
Audio Format: MP2
Audio Bitrate: 128 kb/s
Video Size: 320x240

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">2</node><node key="overall.ui.param">700,640,162,64</node><node key="overall.task.destdir">C:\Downloads\Films\</node><node key="overall.audio.autoSource">false</node><node key="overall.audio.source">FFmpeg</node><node key="overall.audio.format">MP2</node><node key="overall.audio.encoder">FFmpeg</node><node key="overall.video.mode">CBR</node><node key="overall.video.bitrate">512</node><node key="overall.video.format">XviD</node><node key="overall.video.autoSource">false</node><node key="overall.video.autoEncoder">false</node><node key="overall.video.encoder">FFmpeg</node><node key="overall.video.fourcc">XVID</node><node key="overall.container.format">AVI</node><node key="audiofilter.resample.samplerate">44100</node><node key="audiofilter.resample.downSamplingOnly">true</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">320</node><node key="videofilter.scale.height">240</node><node key="videofilter.frame.enabled">true</node><node key="videofilter.frame.fps">22</node></MediaCoderPrefs>
Bye ! :P
pragmaticjim
Beginner
Beginner
Posts: 2
Joined: Tue Nov 09, 2010 2:20 pm

Re: Post your working "Presets" here

Postby pragmaticjim » Wed Nov 10, 2010 3:27 pm

Purpose: Converting Xvid AVIs for playback on Blackberry 8320
Build: Mediacoder 0.7.5.4762
From Xvid (avi) to mp4 for blackberry 8320
Target format:
Video: MPEG4
encoder: FFmpeg
Mode: Average bitrate
Bitrate: 400kbps
Resolution: 320x240
Audio: MP3
Audio Bitrate: 128 kb/s
encoder: FFmpeg
Sample Rate 44100 Hz

Preset:
<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.generic.fileTypes">mp3;mp4;m4a;3gp;3g2;ogg;aac;mp2;mpa;wav;pcm;ra;ram;amr;mpc;wma;ape;apl;flac;wv;als;cda;mpg;mpeg;m2v;mpv;mka;mkv;avi;dat;rm;rmvb;mov;wmv;wm;asf;vob;tp;ts;263;264;avs;flv;sub;cue;m3u;y4m;yuv;divx;vdr;yuv;gif;m4v</node><node key="overall.ui.mode">Advanced</node><node key="overall.ui.optionTab">3</node><node key="overall.ui.param">600,560,238,56</node><node key="overall.task.destdir">C:\Output\</node><node key="overall.task.tempdir">C:\Program Files\MediaCoder\</node><node key="overall.audio.autoEncoder">false</node><node key="overall.audio.encoder">FFmpeg</node><node key="overall.video.bitrate">400</node><node key="overall.video.format">MPEG4</node><node key="audioenc.lame.stereo">Mono</node><node key="audioenc.lame.aq">3</node><node key="audiofilter.resample.samplerate">44100</node><node key="audiofilter.volume.gain">3.000000</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">320</node><node key="videofilter.scale.height">240</node><node key="videofilter.frame.fps">24</node></MediaCoderPrefs>
Jihemtee
Beginner
Beginner
Posts: 3
Joined: Thu Dec 23, 2010 4:46 am

Samsung Galaxy S

Postby Jihemtee » Thu Dec 23, 2010 11:20 pm

I made this preset by recording HD video on the Galaxy S first, then anaysing this source file within Mediacoder, then applying same data on the files I would like to transfer to the unit.
Encoded HD files are working perfectly. Here are the settings:

Build 4797
Container: 3GP
Muxer: MP4Box

Video: H.264
Encoder: x264
Mode: average Bitrate
Bitrate: 1000 Kbps
Resolution: 1280x720
Frame rate: 25.00 FPS
De-Interlace: Auto

Audio: HE-AAC
Encoder: Nero Encoder
Bitrate: 40 Kbps
Sample Rate: 32000 Hz

XML file:
---------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">3</node><node key="overall.ui.param">1049,791,161,141</node><node key="overall.audio.format">HE-AAC</node><node key="overall.audio.encoder">Nero Encoder</node><node key="overall.container.format">3GP</node><node key="overall.plugin.dir">plugins64/</node><node key="audiosrc.winamp.dir">plugins64/</node><node key="audioenc.lame.path">.\codecs\lame64.exe</node><node key="audioenc.vorbis.path">.\codecs\oggenc64.exe</node><node key="audioenc.aacplus.mode">Stereo</node><node key="audioenc.fraunhofer.path">.\codecs\mp3sEncoder64.exe</node><node key="audioenc.musepack.path">.\codecs\mpcenc64.exe</node><node key="audioenc.aac3gpp.path">.\codecs\enhAacPlusEnc64.exe</node><node key="audioenc.wavpack.path">.\codecs\wavpack64.exe</node><node key="audioenc.wavpack.decoderPath">.\codecs\wvunpack64.exe</node><node key="audioenc.flac.path">.\codecs\flac64.exe</node><node key="audioenc.ape.path">.\codecs\MACDll64.dll</node><node key="videosrc.jm.path">.\codecs\ldecod64.exe</node><node key="videoenc.xvid.path">.\codecs\xvidcore64.dll</node><node key="videoenc.x264.profile">High</node><node key="videoenc.x264.level">40</node><node key="videoenc.x264.path">.\codecs\x264_64.exe</node><node key="videoenc.jm.path">.\codecs\lencod64.exe</node><node key="videoenc.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="videoenc.theora.path">.\codecs\theora_encoder_64.exe</node><node key="videoenc.wm.path">.\codecs\wmcodec64.exe</node><node key="muxer.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="audiofilter.resample.samplerate">32000</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">1280</node><node key="videofilter.scale.height">720</node><node key="videofilter.frame.enabled">true</node></MediaCoderPrefs>
------------------------------------------

If HD is not needed, the only parameter changed is resolution which has to be set to 720x480 instead, to fit the exact highest format the Galaxy S is recording files when not in 1280x720.

So, resolution: 720x480

Xml file:
----------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<MediaCoderPrefs><node key="overall.ui.optionTab">5</node><node key="overall.ui.param">1049,791,161,141</node><node key="overall.audio.format">HE-AAC</node><node key="overall.audio.encoder">Nero Encoder</node><node key="overall.container.format">3GP</node><node key="overall.plugin.dir">plugins64/</node><node key="audiosrc.winamp.dir">plugins64/</node><node key="audioenc.lame.path">.\codecs\lame64.exe</node><node key="audioenc.vorbis.path">.\codecs\oggenc64.exe</node><node key="audioenc.aacplus.mode">Stereo</node><node key="audioenc.fraunhofer.path">.\codecs\mp3sEncoder64.exe</node><node key="audioenc.musepack.path">.\codecs\mpcenc64.exe</node><node key="audioenc.aac3gpp.path">.\codecs\enhAacPlusEnc64.exe</node><node key="audioenc.wavpack.path">.\codecs\wavpack64.exe</node><node key="audioenc.wavpack.decoderPath">.\codecs\wvunpack64.exe</node><node key="audioenc.flac.path">.\codecs\flac64.exe</node><node key="audioenc.ape.path">.\codecs\MACDll64.dll</node><node key="videosrc.jm.path">.\codecs\ldecod64.exe</node><node key="videoenc.xvid.path">.\codecs\xvidcore64.dll</node><node key="videoenc.x264.profile">High</node><node key="videoenc.x264.level">40</node><node key="videoenc.x264.path">.\codecs\x264_64.exe</node><node key="videoenc.jm.path">.\codecs\lencod64.exe</node><node key="videoenc.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="videoenc.theora.path">.\codecs\theora_encoder_64.exe</node><node key="videoenc.wm.path">.\codecs\wmcodec64.exe</node><node key="muxer.ffmpeg.path">.\codecs\ffmpeg64\ffmpeg.exe</node><node key="audiofilter.resample.samplerate">32000</node><node key="videofilter.scale.enabled">true</node><node key="videofilter.scale.width">720</node><node key="videofilter.scale.height">480</node><node key="videofilter.frame.enabled">true</node></MediaCoderPrefs>
-----------------------------------------------

Both encodings are working fine on my unit.
Jihemtee

Who is online

Users browsing this forum: Bing [Bot] and 7 guests