Inverse telecine filter does not work properly under ffmpeg source

Discuss about generic usage of MediaCoder.

Moderator: HuggiL

Post Reply
kawamoto76
Advanced
Advanced
Posts: 475
Joined: Sun Dec 14, 2008 4:52 pm
Location: JAPAN

Inverse telecine filter does not work properly under ffmpeg source

Post by kawamoto76 » Fri Jul 24, 2020 3:20 am

With MC-0.8.61,when converting 3,2-pulldowned mpeg2-aac TS file(1920x1080,29.97i) into H.264/ac3(1920x1080,23.976p) m2ts file,
inverse telecine filter works properly if input source is Mencoder. Whereas, it does not work properly when ffmpeg is used for input source.
In telecined 29.97fps TS file, frame sequence is described as (1a1b)(2a2b)(2a3b)(3a4b)(4a4b)......
For example, under Mencoder gives 23.976fps 12341234--- product, whereas under ffmpeg gives 23.976fps 12441244--- product.
Parameter settings are below,
video source decoder: Mencoder or ffmpeg
video output format: H.264
video encoder: x.264
video out Rate mode : AVR
audio source decoder: Auto(Default)
audio output format: AC-3
audio encoder: Auto(ffmpeg)
output container: M2TS
Picture Effect from: Source_Filters
IVTC mode select: File -> Settings -> Video_filters -> Inverse_Telecine_Filter -> pullup

As to conversion speed, maybe from the difference of multithread utilyzation, Mencoder is very slow evenif 16core-32thread system is employed.
In typically case, ffmpeg gives 4.0x, Mencoder gives 1.6x. Mencoder gives much slower speed !
Then, I want to get proper imverse-telecined product with ffmpeg, with reasonable speed.
Is there any necessary additional setting ?
Last edited by kawamoto76 on Sat Aug 01, 2020 7:15 pm, edited 4 times in total.
Akira Kawamoto

kawamoto76
Advanced
Advanced
Posts: 475
Joined: Sun Dec 14, 2008 4:52 pm
Location: JAPAN

Additional: Inverse telecine filter does not work properly under ffmpeg source

Post by kawamoto76 » Sat Jul 25, 2020 11:15 pm

Inspecting the console message,
when Mencoder is employed, statement "Opening video filter: [pullup] " is found in the console, and proper IVTC is done.

On the other hand, when ffmpeg is employed for source filter, word "pullup" is not exist in ffmpeg invoking string.
<Case 1> File -> Settings -> Video_filters -> Inverse_Telecine_Filter -> pullup
console: # ffmpeg -i "E:\VIDEO\test_telecine_AAC.ts" -r 24000/1001 -vf yadif=0 -threads 16 -pix_fmt yuv420p -f yuv4mpegpipe -an pipe:7

this is the same as that of
<case 0> File -> Settings -> Video_filters -> Inverse_Telecine_Filter -> disabled
console: # ffmpeg -i "E:\VIDEO\test_telecine_AAC.ts" -r 24000/1001 -vf yadif=0 -threads 16 -pix_fmt yuv420p -f yuv4mpegpipe -an pipe:7

Then I conclude when ffmpeg is employed as input source, IVTC setting is ignored or invalid in MC 0.8.61.

How can I set "pullup" such as "-r 24000/1001 -vf pullup yadif=0 " ?
Akira Kawamoto

Post Reply