Cannot encode any video with sound other than stereo

Discuss about generic usage of MediaCoder.

Moderator: HuggiL

meddyaas
Beginner
Beginner
Posts: 1
Joined: Sat Sep 09, 2017 12:10 am

Cannot encode any video with sound other than stereo

Postby meddyaas » Sat Sep 09, 2017 12:16 am

Hi all,

Video >
bitrate = 2000
Rate mode = average
Format = H.265
Encoder = NVENC
Source = Auto (FFMEG)

Audio >

Format = AC-3
Encoder = Auto (FFMEG)

Sound >

Anything other than "stereo" and the encode gets stuck on preprocessing and I have to kill the application.

Source is AVC, AC-3 (5.1 channels)

have tried for several days to try and get it to work but nothing works. I would prefer to keep the audio as 5.1
whalemonster
Beginner
Beginner
Posts: 1
Joined: Wed Jun 08, 2016 11:08 am

Re: Cannot encode any video with sound other than stereo

Postby whalemonster » Wed Dec 20, 2017 7:03 am

Me too. :(
stanley
Site Admin
Site Admin
Posts: 4097
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: Cannot encode any video with sound other than stereo

Postby stanley » Sat Jan 06, 2018 9:59 am

Tried AAC?
When things work together, things work.
snotty
Beginner
Beginner
Posts: 6
Joined: Sat Jan 06, 2018 11:32 am

Re: Cannot encode any video with sound other than stereo

Postby snotty » Sat Jan 06, 2018 11:34 am

the settings do not matter one bit, even after a full revert, just changing the Default 'Stereo' to 'Original' will prevent mediacoder from getting past the 'preprocessing' part.
stanley
Site Admin
Site Admin
Posts: 4097
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: Cannot encode any video with sound other than stereo

Postby stanley » Sat Jan 06, 2018 11:57 am

Have you tried updating to latest version. Just tested encoding with 5.1 channel and there is no problem.
If it is stuck at analyzing, it's not the problem of encoding but the original file can't be parsed.
When things work together, things work.
snotty
Beginner
Beginner
Posts: 6
Joined: Sat Jan 06, 2018 11:32 am

Re: Cannot encode any video with sound other than stereo

Postby snotty » Sat Jan 06, 2018 12:12 pm

the exact same original files, using the exact same settings in MC, get recoded by earlier versions of MC.
this bug was introduced last year, i would guess second half. 0.8.50 had the bug for sure.

note: i have to use 0.8.34.5716 for daily recoding purposes, no version since has chosen to run at full speed on my main computer. 0.8.50 DID run at full speed, but was unusable due to this.
snotty
Beginner
Beginner
Posts: 6
Joined: Sat Jan 06, 2018 11:32 am

Re: Cannot encode any video with sound other than stereo

Postby snotty » Mon Jan 08, 2018 7:11 am

i just did some tests.
mediacoder with sound set to original gets stuck on preprocessing with any scene release i can find.
it works with .ts files i recorded myself from TV.
it gets stuck with a file i recoded (with mediacoder) FROM one of these .ts files.
snotty
Beginner
Beginner
Posts: 6
Joined: Sat Jan 06, 2018 11:32 am

Re: Cannot encode any video with sound other than stereo

Postby snotty » Fri Jan 19, 2018 12:39 pm

stanley, fwiw, this IS the latest version i'm talking about (MC full)
flagpole
Modest
Modest
Posts: 232
Joined: Tue Jan 26, 2010 10:12 pm
Contact:

Re: Cannot encode any video with sound other than stereo

Postby flagpole » Sun Jan 21, 2018 9:06 pm

I have never successfully encoded in to AC-3
my quant puzzles http://puzzles.nigelcoldwell.co.uk go look :)
snotty
Beginner
Beginner
Posts: 6
Joined: Sat Jan 06, 2018 11:32 am

Re: Cannot encode any video with sound other than stereo

Postby snotty » Tue Jan 23, 2018 10:58 pm

flagpole wrote:
> I have never successfully encoded in to AC-3

works perfectly though, with earlier versions. only stopped working at some point last year.

Return to “Generic Discussions”

Who is online

Users browsing this forum: No registered users and 10 guests