Change "Frame rate mode" of a video from "Variable" to "Constant"

Discuss about generic usage of MediaCoder.

Moderator: HuggiL

chemikal
Beginner
Beginner
Posts: 1
Joined: Tue Jan 17, 2017 11:40 pm

Change "Frame rate mode" of a video from "Variable" to "Constant"

Postby chemikal » Wed Jan 18, 2017 4:14 am

I did some recordings using Nvidia Shadowplay (detailed info about the videos can be found below), and those videos have a variable frame rate, like detailed below:

Frame rate mode : Variable
Frame rate : 60.000 FPS
Minimum frame rate : 59.230 FPS
Maximum frame rate : 60.790 FPS

The reason I need to do this is I'll work with these videos in Davinci Resolve (video editor), and it doesn't support variable frame rate videos.

Is there a way to transcode them with MediaCoder (my version is MediaCoder-x64-0.8.47.5872, on Windows 10) and change the "frame rate mode" to "constant", in order to have 60 FPS?

Tested format was H.264, and three different encoders: NVENC (my preferred due to its speed), x264, and ffmpeg.

I've tried changing the framerate advanced options ("Do not skip any frame", "Do not increase frame rate", etc) in MediaCoder, but in all tests, the output remains with variable frame rate. I can't find a suitable option to this in MediaCoder....




All info the video:

General
Complete name : C:\VIDEOS\ShadowPlay\FHBDM.mp4
Format : MPEG-4
Format profile : Base Media / Version 2
Codec ID : mp42 (mp41/isom)
File size : 194 MiB
Duration : 1 min 48 s
Overall bit rate : 15.1 Mb/s
Recorded date : 2016
Encoded date : UTC 2016-10-24 23:22:00
Tagged date : UTC 2016-10-24 23:22:00

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.2
Format settings, CABAC : Yes
Format settings, ReFrames : 1 frame
Format settings, GOP : M=1, N=30
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1 min 48 s
Source duration : 1 min 48 s
Bit rate : 14.9 Mb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Variable
Frame rate : 60.000 FPS
Minimum frame rate : 59.230 FPS
Maximum frame rate : 60.790 FPS
Standard : PAL
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.119
Stream size : 192 MiB (99%)
Source stream size : 192 MiB (99%)
Encoded date : UTC 2016-10-24 23:22:00
Tagged date : UTC 2016-10-24 23:22:00
Color range : Limited
Color primaries : BT.601 NTSC
Transfer characteristics : BT.470 System M
Matrix coefficients : BT.601
mdhd_Duration : 108270

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 1 min 48 s
Source duration : 1 min 48 s
Bit rate mode : Constant
Bit rate : 192 kb/s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 spf)
Compression mode : Lossy
Stream size : 2.52 MiB (1%)
Source stream size : 2.52 MiB (1%)
Encoded date : UTC 2016-10-24 23:22:00
Tagged date : UTC 2016-10-24 23:22:00
mdhd_Duration : 108194

Thanks!
Alex3676
Amateur
Amateur
Posts: 15
Joined: Mon Dec 25, 2017 4:54 pm

Re: Change "Frame rate mode" of a video from "Variable" to "Constant"

Postby Alex3676 » Mon Dec 25, 2017 5:22 pm

Video->Mencoder(click font)->advanced->select:["enable software frame skipping" (emulator FPS)] :?: or settings->video sources->Mencoder :arrow: "enable software frame skipping" :mrgreen:
Alex3676
Amateur
Amateur
Posts: 15
Joined: Mon Dec 25, 2017 4:54 pm

Re: Change "Frame rate mode" of a video from "Variable" to "Constant"

Postby Alex3676 » Wed Dec 27, 2017 4:20 am

1. Use FFmpeg as source instead of Mencoder 2. Mark a target frame rate 3. Configure bitrate as CRF or test other settings. 4. If it does not work configure multiplexer and Remux as FFmpeg or leave as Mp4box 5. If it does not work go to advanced settings-video Source-Mencoder-enable enable software skipping 6. Close advanced settings, go back to source and check if FFmpeg is enabled 5. Check if you are using the appropriate codec for MP4 leave in x264 6. Verify the x264 quality presets and prefer CABAC enabled on advanced 7. If you use mp4box go to advanced and enable "Specify frame rate" and disable "Generate compatible Disposivos for Ipod or Psp" (this may interfere or not, if left enabled generates a M4V file). Well that's one way and solved a problem similar to mine, I hope it helps others.

Who is online

Users browsing this forum: No registered users and 11 guests