Subtitles dont work

Discuss about generic usage of MediaCoder.

Moderator: HuggiL

Post Reply
phenomnon
Beginner
Beginner
Posts: 1
Joined: Fri Apr 11, 2014 9:49 pm

Subtitles dont work

Post by phenomnon » Fri Apr 11, 2014 10:04 pm

Hi all,

I am using MediaCoder x64 Vresion 0.8.29 build 5600.
Windows 7 x64. intel i7 920. 12 GB DDR3. NVIDIA Quadro 6000 4GB

I am trying to integrate subtitles into my .mp4 videos, but they are ignored. The steps:

Open MediaCoder
Go to File->Add File
Select my .mp4 video
Go to Subtitle button
The subtitle (has the same name as the video, just the extension is different, of course: .srt) is in the Subtitle File field, so that's fine. All options by default.

I play the video in MediaCoder, no subtitles at all.
I start encoding, no subtitles in the preview.
The enconding finishes, and no subtitles in the video.

There is a problem with SRT subtitles? What am I doing wrong? This worked a couple months ago, and now I can't encode with subtibles. Maybe MP4->MP4+subs is problematic?

meRobs
Expert
Expert
Posts: 3116
Joined: Tue Jun 23, 2009 2:45 pm
Location: Sydney, Australia

Re: Subtitles dont work

Post by meRobs » Fri Apr 11, 2014 11:20 pm

Have you followed the suggestions in the Guide on subtitles?
It is listed under Tips & Guides (link below).
Have you checked out the Tips & Guides for MediaCoder? Try: http://forum.mediacoderhq.com/viewtopic.php?f=17&t=8061
Also, get older builds at: http://www.videohelp.com/tools/MediaCoder/old-versions#download

Kaizhi
Beginner
Beginner
Posts: 1
Joined: Sun Apr 13, 2014 10:53 pm

Re: Subtitles dont work

Post by Kaizhi » Sun Apr 13, 2014 10:59 pm

i got the same prob.....it's the version thingy!!
after i reuse the older version problem solved

flagpole
Modest
Modest
Posts: 257
Joined: Tue Jan 26, 2010 10:12 pm
Contact:

Re: Subtitles dont work

Post by flagpole » Tue Apr 15, 2014 12:50 am

Yeah i'm inclined to agree. i can no loner render subtitles in to the video.

even when running as admin.
my quant puzzles http://puzzles.nigelcoldwell.co.uk go look :)

deepcuts
Beginner
Beginner
Posts: 2
Joined: Fri Apr 25, 2014 2:35 pm

Re: Subtitles dont work

Post by deepcuts » Fri Apr 25, 2014 2:38 pm

I am in the same boat.
From what I can see:
avi files + srt work.
mkv files + srt do NOT work.
The problem is that most of my files are mkv and I am trying to convert them to mp4 with burned in subtitles
MC 0.8.29.5608

stanley
Site Admin
Site Admin
Posts: 4130
Joined: Mon May 15, 2006 7:43 pm
Location: Sydney

Re: Subtitles dont work

Post by stanley » Sun Apr 27, 2014 12:44 am

Try manually setting "video source", e.g. mencoder or avisynth.
When things work together, things work.

meRobs
Expert
Expert
Posts: 3116
Joined: Tue Jun 23, 2009 2:45 pm
Location: Sydney, Australia

Re: Subtitles dont work

Post by meRobs » Sun Apr 27, 2014 10:26 am

If you had read the Guide on Subtitles, listed under Tips & Guides (link below), you would have noted that the testing done for that guide used MEncoder as the Video Source. This is especially so if you had converted to MP4 using the suggested settings in the Encoding Guide where Note 17 mentioned that subtitles may not work unless you use MEncoder.

Sorry for sounding critical, but I am a bit disappointed that the info given in the Guides is not being used.
Maybe they are not written well enough?
Have you checked out the Tips & Guides for MediaCoder? Try: http://forum.mediacoderhq.com/viewtopic.php?f=17&t=8061
Also, get older builds at: http://www.videohelp.com/tools/MediaCoder/old-versions#download

deepcuts
Beginner
Beginner
Posts: 2
Joined: Fri Apr 25, 2014 2:35 pm

Re: Subtitles dont work

Post by deepcuts » Sun Apr 27, 2014 6:21 pm

I do apologize for not understanding the FAQ, but I did read it.
"Moreover, it was found that success may require the use of MEncoder as the video 'Source'. "

The problem is that by default, under Source, I can see MEncoder, but it was grayed out and Auto selected.
My logic was that MEncoder will be used as default.
I was wrong. I needed to uncheck auto.
Now mkv files work with external srt.

Thank you for the info

Post Reply