How to use quick sync and best encoder settings for Haswell

Share with other users your experience in using MediaCoder.
Valagard
Amateur
Amateur
Posts: 14
Joined: Mon Mar 17, 2014 9:30 am

How to use quick sync and best encoder settings for Haswell

Postby Valagard » Tue Mar 18, 2014 12:22 pm

So I spent the last two weeks trying to figure out why I couldn't get quick sync to work, every time I tried, it would say I "Didn't have a GPU" or when I selected it manually, it would refuse to encode

Anyways, I figured out how to get Quick sync working with my Haswell, and also best settings possible

First, you have to make sure Quick Sync is working, if you can't install the Intel GPU drivers, quick sync is not working

Second, you need to set up it up like this

(!empty($user->lang['IMAGE'])) ? $user->lang['IMAGE'] : ucwords(strtolower(str_replace('_', ' ', 'IMAGE')))

You have to turn off AUTO under encoder, manually select Intel Encoder, and then GPU will check itself, if you have it on auto, and try to just tick GPU, it will say it can't find a GPU to encode with. Again, click off auto, then click Intel Encoder, and if quick sync is enabled it should go on

Second, and I can't stress this enough, the reason everyone can't encode files even if they do this, is cause use D3D is turned on to either DX9 or DX11. This ONLY works if you have just a intel GPU in your computer and NO secondary GPU, if you have a secondary GPU, it will always fail to encode. Set this to disabled

Now comes settings, I am for best compression while keeping quality, so I set GOP to 500, if you're encoding videos for media devices, set GOP to 250. GOP 500 also for some reason looks the best, though 250 is a great midpoint between seeking and video quality. Why this happens I dunno, but setting a GOP of like 60-100 looks incredibly worse than a GOP of 500

Now, you would think having 8 ref frames would look better than having 3 ref frames and LA BRC set to 100, but you're wrong, drastically wrong. Not only does 8 ref frames look far, and I mean far worse, but it actually takes 28% longer to encode than just using 3 ref frames and LA BRC set to 100.

*Update!* I have since found out ages later through testing, that having OpenCL is causing the issue with QuickSync and being unable to go any higher than 8 ref frames, with OpenCL turned off I can now do 8 Ref frames with LA BRC set to 100, and the encodes look phenomenal.

Why not set 8 ref frames and LA BRC to 100 then? Cause as of right now, if you try to set higher than 3 ref frames while having LA BRC set to ANY amount, for some reason it causes the encoder to crash and stop working. I hope future versions allow you to set higher ref frames while keeping LA BRC on, but as of right now it doesn't work

Even with that said, 3 ref frames and LA BRC set to 100 looks vastly better than 8 Ref frames and LA BRC turned off, and like I said, 3 ref frames and LA BRC set to 100 encodes vastly faster, while looking vastly better

Anyways, I hope this helps clear up the confusion I am seeing all over these forums, and why people can't get Quick Sync to work even if its enabled in their system, took me 5-6 days of digging around tech documents and finding out how Quick Sync worked exactly, plus about a dozen hours playing with Media coder settings to figure out the best ones.

Enjoy everyone!

*EDIT* QuickSync is known to not work/turn on unless its been activated by having a monitor turned on, even if its not connected.

http://i.imgur.com/lZusvCp.png Is an example of how you do this, in this case, you make a 3rd monitor in my case by clicking detect display, then setting up as shown. This turns on QuickSync and allows any other programs on the computer to use it. intelHD needs to be actively used by a monitor in order for the computer to use QuickSync, why I dunno.

You don't need to have a monitor hooked up, but this is one way to do it.

Return to “Tips & Tricks”

Who is online

Users browsing this forum: No registered users and 2 guests